Browse Source

v1.3.0: update to latest rsa-compat

tags/v1.3.0
AJ ONeal 5 months ago
parent
commit
37ec898e9e
2 changed files with 51 additions and 2 deletions
  1. 49
    0
      package-lock.json
  2. 2
    2
      package.json

+ 49
- 0
package-lock.json View File

@@ -0,0 +1,49 @@
1
+{
2
+  "name": "acme",
3
+  "version": "1.3.0",
4
+  "lockfileVersion": 1,
5
+  "requires": true,
6
+  "dependencies": {
7
+    "@coolaj86/urequest": {
8
+      "version": "1.3.7",
9
+      "resolved": "https://registry.npmjs.org/@coolaj86/urequest/-/urequest-1.3.7.tgz",
10
+      "integrity": "sha512-PPrVYra9aWvZjSCKl/x1pJ9ZpXda1652oJrPBYy5rQumJJMkmTBN3ux+sK2xAUwVvv2wnewDlaQaHLxLwSHnIA=="
11
+    },
12
+    "acme-v2": {
13
+      "version": "1.6.0",
14
+      "resolved": "https://registry.npmjs.org/acme-v2/-/acme-v2-1.6.0.tgz",
15
+      "integrity": "sha512-+vCD+j87eEQhdiqSVA9KT97+EGYbkVTgSqxQ37y9aM/3uExi2U+UM4EQEAIRSV/DWZ6oqeRPe+dha8h+PtNdwQ==",
16
+      "requires": {
17
+        "@coolaj86/urequest": "^1.3.6",
18
+        "rsa-compat": "^2.0.6"
19
+      }
20
+    },
21
+    "eckles": {
22
+      "version": "1.4.1",
23
+      "resolved": "https://registry.npmjs.org/eckles/-/eckles-1.4.1.tgz",
24
+      "integrity": "sha512-auWyk/k8oSkVHaD4RxkPadKsLUcIwKgr/h8F7UZEueFDBO7BsE4y+H6IMUDbfqKIFPg/9MxV6KcBdJCmVVcxSA=="
25
+    },
26
+    "keypairs": {
27
+      "version": "1.2.14",
28
+      "resolved": "https://registry.npmjs.org/keypairs/-/keypairs-1.2.14.tgz",
29
+      "integrity": "sha512-ZoZfZMygyB0QcjSlz7Rh6wT2CJasYEHBPETtmHZEfxuJd7bnsOG5AdtPZqHZBT+hoHvuWCp/4y8VmvTvH0Y9uA==",
30
+      "requires": {
31
+        "eckles": "^1.4.1",
32
+        "rasha": "^1.2.4"
33
+      }
34
+    },
35
+    "rasha": {
36
+      "version": "1.2.5",
37
+      "resolved": "https://registry.npmjs.org/rasha/-/rasha-1.2.5.tgz",
38
+      "integrity": "sha512-KxtX+/fBk+wM7O3CNgwjSh5elwFilLvqWajhr6wFr2Hd63JnKTTi43Tw+Jb1hxJQWOwoya+NZWR2xztn3hCrTw=="
39
+    },
40
+    "rsa-compat": {
41
+      "version": "2.0.6",
42
+      "resolved": "https://registry.npmjs.org/rsa-compat/-/rsa-compat-2.0.6.tgz",
43
+      "integrity": "sha512-bQmpscAQec9442RaghDybrHMy1twQ3nUZOgTlqntio1yru+rMnDV64uGRzKp7dJ4VVhNv3mLh3X4MNON+YM0dA==",
44
+      "requires": {
45
+        "keypairs": "^1.2.14"
46
+      }
47
+    }
48
+  }
49
+}

+ 2
- 2
package.json View File

@@ -1,6 +1,6 @@
1 1
 {
2 2
   "name": "acme",
3
-  "version": "1.2.0",
3
+  "version": "1.3.0",
4 4
   "description": "The bare essentials of the ACME (Let's Encrypt v2) API. This is a low-level library for building high-level clients.",
5 5
   "homepage": "https://git.coolaj86.com/coolaj86/acme.js",
6 6
   "main": "node.js",
@@ -25,6 +25,6 @@
25 25
   "author": "AJ ONeal <coolaj86@gmail.com> (https://coolaj86.com/)",
26 26
   "license": "MPL-2.0",
27 27
   "dependencies": {
28
-    "acme-v2": "^1.3.1"
28
+    "acme-v2": "^1.6.0"
29 29
   }
30 30
 }

Loading…
Cancel
Save